It is currently Sun Sep 24, 2017 12:07 am

All times are UTC - 5 hours




 Page 1 of 1 [ 4 posts ] 
Author Message
 Post subject: OpenAL VMK 6 - Ogg Vorbis Setup
PostPosted: Sat Jul 24, 2010 7:31 am 
Site Admin

Joined: Sun Feb 11, 2007 8:59 am
Posts: 1105
Location: Ontario Canada
The audio engine will be able to load and playback ogg vorbis files when we are done with it. For us to use ogg vorbis we first need to download and install the necessary SDK files. That is what I do in this VMK.

http://www.vorbis.com/


Offline
 Profile  
 
 Post subject: about libvorbis
PostPosted: Sun Jul 25, 2010 10:27 pm 

Joined: Sat Aug 16, 2008 7:58 am
Posts: 448
I followed everything you have done to the "T" twice and when I build the OGG static library it works fine. When I do the VORBIS static library. I get this message from VS:

2>c:\program files\ogg vorbis\libvorbis-1.3.1\include\vorbis\codec.h(26) : fatal error C1083: Cannot open include file: 'ogg/ogg.h': No such file or directory

I set up the environment variables for both the OGG_SDK and VORBIS_SDK properly, and I set up the properties to use the environment variables. I am stumped on why VS is saying it can not find the file or path. The only difference that I am doing is that I am using the VS2008 version not the VS2005, but I don't think that should make a big difference. Any thoughts?


Offline
 Profile  
 
 Post subject:
PostPosted: Mon Jul 26, 2010 5:23 am 
Site Admin

Joined: Sun Feb 11, 2007 8:59 am
Posts: 1105
Location: Ontario Canada
A few things to check:
* Check the spelling of the environment variable
* Check the path you set in the environment variable for spelling errors
* Close and reopen Visual Studio
* Set the configuration to Release
* Open project properties. Make sure you have the Release configuration selected
* Check 'Additional include directories' for spelling mistakes
* Check all projects in the solution by clicking through the project name when the project properties dialog is open.

Let me know what you discover.


Offline
 Profile  
 
 Post subject: LibVorbis static build
PostPosted: Tue Jul 27, 2010 4:06 pm 

Joined: Sat Aug 16, 2008 7:58 am
Posts: 448
Ok I retried everything, I made sure there where no spelling errors. I got the same error with opening the files. I keep getting this when I use build entire sulotion from the build drop down menu. So, I tried this instead. I did a clean solution. Then I selected the libvorbis_static project and built that seperately, then I did the libvorbisfile project and built that serperately, and both built fine (Release Version). I am hoping this will suffice for the next few VMKs. I also checked the directory on my computer and looked inside the Win32/Release folder and found both .lib files


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Jump to:  

cron